Virtualbox 5.1 & Vagrant 1.8.4


after releasing the new shiny Virtualbox 5.1 there is few things need to do with Vagrant 1.8.4 so it will work

my host machine is Windows but I guess many will find the right path quite easy.

under C:\HashiCorp\Vagrant\embedded\gems\gems\vagrant-1.8.4\plugins\providers\virtualbox

edit the file plugin.rb and meta.rb

add

autoload :Version_5_1, File.expand_path(“../driver/version_5_1”, __FILE__)

to

module Driver
autoload :Meta, File.expand_path(“../driver/meta”, __FILE__)
autoload :Version_4_0, File.expand_path(“../driver/version_4_0”, __FILE__)
autoload :Version_4_1, File.expand_path(“../driver/version_4_1”, __FILE__)
autoload :Version_4_2, File.expand_path(“../driver/version_4_2”, __FILE__)
autoload :Version_4_3, File.expand_path(“../driver/version_4_3”, __FILE__)
autoload :Version_5_0, File.expand_path(“../driver/version_5_0”, __FILE__)
end

or get plugin.rb and meta.rb from Vagrant Github

then under C:\HashiCorp\Vagrant\embedded\gems\gems\vagrant-1.8.4\plugins\providers\virtualbox\driver add the file version_5_1.rb from Vagrant Github

that’s it
good luck

Advertisements
This entry was posted in Oracle and tagged , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s